API Access


#1

when trying to use the CURL command to execute sample commands on a server, I get the following error:

curl: (51) Unable to communicate securely with peer: requested domain name does not match the server’s certificate.
[root@x]#

I understand the error. I am not sure how to fix it.
Any help would be great.


#2

I have created a cert file local to the server and gave the cert information via command line:

curl --crlfile ./public.cer

but i get this:
curl: (82) Failed to load CRL file (path? access rights?, format?)
[root@x]#

not sure what that means exactly.


#3

If you trust the destination you could disable curl’s validation of the server certificate by using the insecure flag

curl -k https://eda.server.com/

As for using the cert file are you sure the file is in the path you defined, and has correct permissions rights and is in a PEM format?


#4

that worked…
THANKS!